Are you an STP app user? Check out our IMPORTANT announcement CLICK HERE FOR MORE INFO.

Single User Mode but Reckon thinks I am in Multi User Mode

PearlPearl Member Posts: 10

Hi

I have Reckon desktop set to Single User Mode and I have also gone to File>Utilities and changed the mode from "Stop Hosting Multi User Access" , restarted my laptop, but continue to have the issue upon opening Reckon where I get the message:-

Reckon Accounts was unable to open the company file because the file is in use. Another person may be in the process of opening the company file.

I am the only user - why does this message keep appearing? Is there something I need to sort with compatibility settings possibly? I am using Windows 10 and Reckon Accounts Premier 2019.

Thanks.

Pearl

Comments

  • John GraetzJohn Graetz Member Posts: 1,713 ✭✭✭

    Hi Pearl. I don't know if this will help, but it is worth a try. Find the Program icon on your desktop. right click on it and then select Run as administrator. See if that makes any difference. I am assuming that you only have the program on your laptop and not running on a server. Another suggestion is to copy your file (using File Explorer) to another directory and then trying to open it from there instead.

    John L G

  • PearlPearl Member Posts: 10

    Thanks John. Yes I do already have the icons set to Run as Administrator - has not made any difference.

    Yes I only have the program on my laptop. I will explore the other suggestion thanks. It is very frustrating having to keep going around in loops each time I open (or try to open) Reckon. If I click OK to the multi user message I can then open, sometimes after the first time and sometimes can take two or three goes - but it should not be happening at all.

    Appreciate your reply - thanks.

    Pearl

  • John GraetzJohn Graetz Member Posts: 1,713 ✭✭✭

    Pearl. If you can ever get out of multi-user mode, I would suggest that you rebuild your company file three times and see if that helps. Things like rebuild and backup can only be one in single user mode.

    John L G

  • PearlPearl Member Posts: 10

    Ok thanks for trying to help John. I will try that if possible at some stage.

    Hmmm reading that again though I am able to backup ok. It's very odd - everything is set to single user but upon opening Reckon thinks I am in multi user. Annoying.

    Pearl

  • Kris_WilliamsKris_Williams Member Posts: 1,781 ✭✭✭

    One of my clients has the same problem, opens every time in multi user mode but she doesn’t have any other problems so just leaves it

  • John GraetzJohn Graetz Member Posts: 1,713 ✭✭✭

    Pearl. Very odd indeed and does not seem to make a great deal of sense. If you are able to do a backup, then you should be able to do a rebuild. I would strongly recommend that you do that three times, because that tends to fix a multitude of problems. I have seen instances where a problem has not been fixed until that third rebuild is done.

    John L G

  • PearlPearl Member Posts: 10

    Thanks Kris - so do you mean she has to do the loop to get Reckon to open also, as in say Ok once, twice, three times before Reckon will open?

    Thanks John - I will give that a go and see if it helps.

    Pearl

  • John GraetzJohn Graetz Member Posts: 1,713 ✭✭✭

    Pearl. When you say that you have the icons set to run as Administrator, are you actually right clicking on the program icon and then selecting Run as administrator? Unless I do this there are a number of functions which will not work unless I keep on clicking the action multiple times until it eventually works. Of course that is nowhere near acceptable, hence the reason that I right click and select.

    John L G

  • PearlPearl Member Posts: 10

    Yes I am thanks John.

  • Kris_WilliamsKris_Williams Member Posts: 1,781 ✭✭✭

    You can right click on the icon and select properties and make the default Run as Administrator, this way you don’t have to do it every time.

  • PearlPearl Member Posts: 10

    Yes I am aware of that thanks Kris and that is what I have done.

  • John GraetzJohn Graetz Member Posts: 1,713 ✭✭✭
    edited July 20

    Thanks for that piece of advice, Kris!! I have now changed my properties so that means that i will have a couple less clicks in the future. Much appreciated!

    John L G

  • Kris_WilliamsKris_Williams Member Posts: 1,781 ✭✭✭

    I just asked my client who has a similar issue, but no it’s not a loop, she just enters username and password, it goes in as multi user mode but she can easily switch when she needs to backup etc

  • PearlPearl Member Posts: 10

    Thanks for asking Kris. John I have just asked to do the rebuild and each time once the backup is done this is the message I get so I guess that means the rebuild has not been done. I'm pretty sure from memory there is a "Rebuild successful or complete message" that normally appears?

    This message below has now appeared and I have had to do the loop five times to be able to open the company file.

    I have now searched the knowledge base and found a link regarding these error codes and have followed through setting up the exceptions.

    https://help.reckon.com/article/u54z9f5opw-kba-3599-error-6000-816-unable-to-open-database

    Will see if anything alters once I do a shut down or restart of the laptop and advise.

    Pearl


  • John GraetzJohn Graetz Member Posts: 1,713 ✭✭✭

    Well at least you now have something that you can try, Pearl. Alternatively, the other option is to ring Reckon Technical Support and see what they have to say, but maybe they might just tell you to follow the instructions in the KB article.

    John L G

  • PearlPearl Member Posts: 10

    Yes thanks John. I have followed all the steps, restarted my laptop and am now back to the multi user message.

    I have a perpetual licence so Reckon won't give me any support after the first twelve months, which is the case.

    Anyway, thanks for suggestions.

    Pearl

  • Linda ABCLinda ABC Member Posts: 1,159 ✭✭✭
    edited July 20

    Pearl - in addition to the steps in the KB article - I would suggest:

    1. Make sure you do a hard shutdown and restart of your laptop - this means holding the shift key down while selecting shutdown or restart - and holding it down until the system closes Windows. (fixes so many problems you wouldnt believe! W10 doesnt not shutdown fully when you choose normal shutdown or restart without holding shift key).
    2. Start Reckon using desktop icon (NOT a link to a datafile)... instead of logging in to the file, escape back to the No Company File open screen...then choose Open an existing company - and while browsing for the location of the datafile - make sure that the Open File in Multi User mode is NOT ticked - see image

    Make sure the file shuts down correctly each time you finish with it - in my experience that message you are getting happens when the file isnt logged off/closed properly.

    I am wondering if this may be happening due to errors on your hard drive? so I would suggest running some check disk tools on the machine to make sure everything is good... if there are bad sectors on the drive - this could be causing it not to shut down properly?

  • PearlPearl Member Posts: 10

    Interesting thanks Linda.

    I have now done the hard shutdown and started Reckon with the desktop icon (I usually open with using a shortcut icon) - the first thing that appeared was the multi user message again - can you post the image for me you mention in the last message?

    Thanks.

    Pearl

  • John GraetzJohn Graetz Member Posts: 1,713 ✭✭✭

    Pearl. One way or another we should be able to beat this. I have another suggestion for you as follows:

    1. Copy the company file to a different directory.
    2. Rename the new file by adding a suffix e.g. current is ABC then rename the new one to ABCnew.
    3. Start Reckon but instead of opening the old file, navigate to the directory where the copied file is located and try opening that and see what happens.

    As I see it, logic would suggest that there may be three reasons for your problem:

    A. There is a problem with your computer (unlikely in my mind)

    B. There is a problem with the program (could be, but I have my doubts)

    C. There is a problem with the file or something related to the location of it or something that is remembered from from previous instances when you have either opened or closed it.

    My belief is that by following my suggested steps 1, 2 and 3 above, all possibilities will be sorted out, one way or another.

    John L G

  • ZappyZappy Accredited Partner Posts: 4,768 ✭✭✭

    Did you get it sorted? Call me Zappy 0407744914

  • ZappyZappy Accredited Partner Posts: 4,768 ✭✭✭

    John mate, its all sorted. I spoke to Pearl this morning. Cheers

  • PearlPearl Member Posts: 10

    Hi John & Kevin

    Thanks for your further thoughts John - I hadn't had a chance to get back to looking at things until this morning. And before trying anything I gave Kevin a call to discuss his thoughts.

    And I'm all sorted and all good!! Thanks so much Kevin - really appreciate you taking the time to help.

    Seems I had veered way off the Reckon track by putting my company files in Dropbox (something I hadn't even thought to mention - so sorry). I've had them in there for ages as for three years I was using Reckon in Parallels on a Mac and accessing my company files that way ok. Then in reverting back to the PC a couple of months ago I left them there, not even thinking about the Reckon preferred directory path.

    Following Kevin's suggestion I deleted all the .nd files and then copied the .QBW files only across to the proper directory and I can now open Reckon first time!

    So, apologies for taking up time but much appreciate all the help.

    Pearl

  • John GraetzJohn Graetz Member Posts: 1,713 ✭✭✭

    Well at least you got it solved with Kevin's help, which is the main thing.

    John L G

  • ZappyZappy Accredited Partner Posts: 4,768 ✭✭✭

    John G, in the words of that brilliant songsmith James Taylor, that's why I'm here. Zappy out;)

Sign In or Register to comment.