MFA not working

LynneLynne Member Posts: 66
edited August 15 in Accounts Business Range
I set up MFA last week and everything was working fine.  Then I decided to install Authy on google chrome so that I had a back up if my phone wasn't available.  I connected both devices and they both seem to recognise each other, however when I now try to log into GovConnect the MFA says 'Please type the correct code' and will not accept the code from my phone or from google chrome.

image

I have already done my first payroll run for the new financial year and need to upload the STP file to the ATO.

Please help.

Lynne

Comments

  • RavRav Administrator Posts: 10,925 Administrator
    edited August 15
    Hi Lynne,

    You can't have two different sources of MFA for the same service.

    If you set up the MFA on your phone with Google Authenticator initially then that will be your source for MFA codes for the STP service.

    If you want to change to a web based browser extension, then you need to first revoke the current MFA which you can do from your profile settings in the Reckon Portal. Then set up MFA again using the web extension.

    There's some info on setting up MFA with a web extension here - 

    I don't have a smartphone, how do I register Multi-Factor Authentication (MFA) for Single Touch Payroll?
  • LynneLynne Member Posts: 66
    edited July 2018
    It won't let me revoke the current MFA as it needs an MFA code and as I said above it keeps saying it is incorrect.
  • RavRav Administrator Posts: 10,925 Administrator
    edited July 2018
    Yes that's correct, you'll need to input the relevant MFA code from the original source in order to revoke it. 
    You've mentioned in your first post that you had set it up on your phone first so you'll need to get the MFA code from there to complete the process.
  • SpillySpilly Member Posts: 212
    edited July 2018
    Why can’t you have multiple MFA devices? I use multiple devices MFA all the time. https://support.google.com/accounts/answer/1066447?co=GENIE.Platform=Android&hl=en
  • LynneLynne Member Posts: 66
    edited March 2019
    Hi Rav, it won't let me use the code from my phone (which was the original source), it keeps saying 'Please type correct code'.
  • RavRav Administrator Posts: 10,925 Administrator
    edited July 2018
    Hi Lynne,
    The most common cause & fix to this is to go into the Google Authenticatior app settings and sync the time settings to Google's servers (see screenshot below).

    Try the above out and see how you go.. OR did you delete the Google Authenticator app since setting it up successfully and before revoking access?

    image
  • Lisa SeierupLisa Seierup Member Posts: 6
    edited July 2018
    I have downloaded the Google Authenticator app, scanned the barcode and get the reckon portal services code.... but it doesn't matter how many time I try it won't accept the code. I have tried reinstalling the app, I have restart my phone, I have restarted the Portal and nothing. I don't want to use the web browser method I only want to use my phone. I can not find how to get to the settings you show above
  • RavRav Administrator Posts: 10,925 Administrator
    edited July 2018
    Hi Lisa,
    Are you using the Android or iOS version of the Google Authenticator app?
  • LynneLynne Member Posts: 66
    edited July 2018
    Hi Rav, I have fixed the authenticator issue and can now access Gov connect again.  I have also successfully uploaded my first pay run.

    Can you let me know when the share file functionality will be available?  I am trying to decide whether to use this or put authenticator on my desktop instead of phone.

    Thanks

  • RavRav Administrator Posts: 10,925 Administrator
    edited July 2018
    Hi Lynne,
    We're aiming to release sharing functionality this week hopefully, the team just need to work out a few kinks. We'll have more info on the Community about it as soon as its ready
Sign In or Register to comment.