Marking Pay Run as paid

iangc
iangc Member Posts: 20

Hi team, trying to mark a pay run as paid but keep getting the following error message - There was an issue marking this pay run as paid. We had trouble marking this pay run as paid. Delete the draft pay run and create a new one.

I subsequently deleted the pay run and started a new pay run only to have the same error!!! I do not wish to create a third pay run so wondering if there's an issue currently with the STP app?

Cheers

Comments

  • Rav
    Rav Administrator, Reckon Staff Posts: 15,094 Community Manager Community Manager

    Hi @iangc

    Have you added any new employees recently? ie. since the last time you were able to create a pay run successfully?

    If so, I've got a couple of recommendations to check in the new employee's profile information which hopefully rectifies the problem.

    Go into the employee's profile and check their address details and confirm that the address type selection is set to Australia and not International.


    Once the above is done, save the employee profile info. Delete that draft pay run and recreate it and send through the STP submission.

    Let me know how you get on.

  • iangc
    iangc Member Posts: 20

    Hi Rav, thanks for the prompt reply. I can confirm no new employees were added since last pay run. I've also just checked all active employees and all address fields are correct and marked Australia. I've also logged out and back in several times....still receiving the error.

  • Rav
    Rav Administrator, Reckon Staff Posts: 15,094 Community Manager Community Manager

    Thanks for that @iangc

    How many employees do you have included in this pay run?

    If there are multiple, try the following -

    • Look at the first employee in the pay run and take note of their pay details eg. earnings, super etc then remove that employee from the pay run
    • Mark the pay run as paid
    • Switch the pay run back to draft status
    • Add the employee from step 1 back into the pay run along with their earnings etc
    • Mark the pay run as paid again


    If there is only one employee in the pay run, try the following -

    • Switch the pay run to draft
    • Change the Pay Date
    • Remove the earning item from the employee in the pay run
    • Re-add the earning item back in
    • Change the Pay Date back to the correct date
    • Mark the pay run as paid


    I know there's a fair bit there and our team is currently investigating some of the causes of this but in the interim, I'd recommend giving the above workaround a go when you can.

    Let me know how you get on.

  • iangc
    iangc Member Posts: 20

    Hi Nav, I've just logged into the Web portal to see if I could mark pay run as paid. Noticed error message stating Journal transaction(s) nust be entered! What does that refer to? Cheers

  • iangc
    iangc Member Posts: 20

    FYI this pay run has eight employees.

  • Rav
    Rav Administrator, Reckon Staff Posts: 15,094 Community Manager Community Manager

    Ok cool, in that case the steps from the first workaround applies and it can be actioned in either the mobile app or the web access for your Payroll App account.

    Let me know how you go.

    Cheers

  • iangc
    iangc Member Posts: 20

    Hi Nav, that workaround did the trick! May I ask what has caused the error...is it something we've done on our end?

  • Rav
    Rav Administrator, Reckon Staff Posts: 15,094 Community Manager Community Manager

    Awesome, glad to hear its sorted for you @iangc 🙌

    I'm not across the finer details when it comes to dev jargon but from what I understand its certainly something on our end rather than anything you've done in the app. I believe its related to an incorrect API call that needs remediation which our team have already isolated and are investigating at the moment.