401 Authorization failed in Provisioning service. User NOT Authorized for file. User not found.

Nghi ChuNghi Chu Member Posts: 7
edited February 2019 in Accounts Hosted
Hi there,

1) I am trying to test using Reckon Accounts Hosted Postman Collection, but all of post requests returned this error (401 Authorization failed in Provisioning service. User NOT Authorized for file. User not found.), just except Refresh Token request. Could you please show me how to set the environment correctly? (I already followed the guide in https://reckon.helpdocsonline.com/api-reckon-accounts-hosted-postman-collection with user Admin/admin).

2) In every post request, I found that we need to put data into QBXML part of body. What should I put into them? Is there any document that show what to put it them such as what kind of data for what tags?

Thank you.
Nghi.

Comments

  • Darryl RossDarryl Ross Member Posts: 4
    edited February 2019

    Try using the user id instead of the username to authenticate.

     

    There is some documentation here on what to put in the QBXML:

     

    https://developer-static.intuit.com/qbsdk-current/common/newosr/index.html

     

    I found that the site works best if you open it in Firefox.
  • PhuongDoPhuongDo Reckon Developer Partner Posts: 212 ✭✭
    edited January 2019
    It is a good link, and remember to choose Max SDK Version = 6.0


    Phuong Do / Reckon Developer Partner

    [email protected]

  • Nghi ChuNghi Chu Member Posts: 7
    edited January 2019
    Thank you, guys. I'll check it out.
  • Nghi ChuNghi Chu Member Posts: 7
    edited February 2019
    Hi Darryl,

    > Try using the user id instead of the username to authenticate.
    Is there any other suggestion to authenticate? I tried using user id but it still responsed the same error (401 Authorization failed in Provisioning service. User NOT Authorized for file. User not found.).

    Thank you.
  • Darryl RossDarryl Ross Member Posts: 4
    edited February 2019
    Log into your reckon hosted account and check that the path to the company file is the same as what is set in the Postman environment settings.

    Also make sure that you can open the company file in Reckon Hosted with the file_username and file_password settings from the Postman environment settings.
  • Nghi ChuNghi Chu Member Posts: 7
    edited February 2019
    Hi Darryl,

    I tried all the suggested, but I am still getting the 401 error. Is there anything else that I can try, please help. Thank you.
  • IftiIfti Reckon Staff Posts: 459 ✭✭
    edited February 2019
    Hi Nghi,

    Can you please email [email protected] and we'll look further into it?

    401 means the token you passed wasn't correct. We need to check that in details to see what steps you took.

    Thanks

    Ifti
Sign In or Register to comment.