Multi users slow access to datafile. Constant Company file in use. Another user is performing a task messages

  • 1
  • Problem
  • Updated 1 month ago
We are using Reckon accounts 2017 premier - 5 licenses with datafile hosted on a server.
Increasingly we are having problems with multiple users accessing the datafile. They can log in OK, but whenever someone tries to process a transaction we get the Company file in use, or another user is performing a task... please wait. On some occasions it will give the name of the user that is apparently performing the task, however they are not doing anything at all. We get these messages when no one is performing any tasks. It has got to the stage where we now only let one person at a time log in to perform their work. Obviously this is not sustainable.

Does anyone know of a fix?
Photo of sheusz

sheusz

  • 120 Points 100 badge 2x thumb

Posted 4 months ago

  • 1
Photo of Linda Putland

Linda Putland, Accredited Partner

  • 15,774 Points 10k badge 2x thumb
When was the last time you cleared your TLG file... it will only clear automatically when a full Backup with Verify is run... if that hasnt been done in a while then definitely close everyone out - go to Admin Single User and do this...  check the size of the .TLG file before and after... this file lives in the same place as your datafile... if this file is more than half the size of the actual datafile it could be causing your issues...  when the full backup with verify is completed and the .tlg goes back to a small size - you should see an improvement in performance.
Photo of sheusz

sheusz

  • 120 Points 100 badge 2x thumb
Hello Linda

Thanks for the reply. The TLG is 65,856 KB. The QBW file is 971,216 KB. In the past we have tried to do a backup & verify however it always fails (has done for years). We currently backup the datafile (daily)  using our server backup.

I've manually deleted the TLG file and relaunched but am still having the same issue. In this last instance two people log in OK, then a third tries to then gets the message Company File in Use, followed by An Unknown user is performing a task... but no one is.

Any other ideas?

Photo of Linda Putland

Linda Putland, Accredited Partner

  • 15,774 Points 10k badge 2x thumb
ok - thanks for the further info (bit of a concern about the backup failing - but thats another question)... does the third person actually get into the file - but get the company file in use when they are going to a specific area of the program?  EG invoices?   Sounds like you probably should be:
  • log out all users
  • take a copy of the file (unless you can do a backup?)
  • go to single user with Admin as the user
  • resort your Account list, item list and name list (do this one by open Write Cheques, clicking on Payee, press Ctrl+L, then resort this list)
  • Now choose File - Utilities - Rebuild but hold the Ctrl key down while you select rebuild - it will ask if you want to rebuild without backing up - say yes... 
  • After the rebuild finishes - choose File Utilities - Verify ... its worth letting this run through to see if there are issues with the file
  • If there are issues - rebuild x 2 more times - then Verify again
  • Now go multi user again
  • Login user number 3 first, then number 2 and number 1 and see if you have same problem?
Photo of sheusz

sheusz

  • 120 Points 100 badge 2x thumb
Hi Linda

Thanks for the prompt reply. I'll have to try this at the end of the day. Sounds like it will take a while.

To be clear users 1, 2 or 3 (up to 5) can be any one of the five users, not a particular user.

I keep thinking that this could be more related to the Reckon Accounts Database Server Manager. Could that be a possibility? It is apparently monitoring the file location, but there is no way to prove this.
Photo of Linda Putland

Linda Putland, Accredited Partner

  • 15,774 Points 10k badge 2x thumb
Usually if they can log in - then you wont have any issues...how long has this problem been ocurring - can you trace it back to any kind of event on the computer system? ie new machine installed, change of antivirus software, windows update etc?  try turn off all your firewalls and antivirus programes - then have everyone log in again - does that make a difference?  sorry, lots of possibilities here - probably need to see the environment and the problem in action...?
Photo of sheusz

sheusz

  • 120 Points 100 badge 2x thumb
Hi Linda

I can't say that I can point this to a single event. It's been getting progressively worse over the last 5-6 months, but has become more serious over the last few weeks.

Apart from dreaded windows updates (server based) there hasn'e been any other hardware/software changes.

I'll take on your suggestions, but as you can imagine it will take some time.
Photo of Linda Putland

Linda Putland, Accredited Partner

  • 15,774 Points 10k badge 2x thumb
Ok - expect if you have a file server you most likely have an IT expert you use?  perhaps ask them to review this KB articile http://kb.reckon.com.au/issue_view.asp?ID=220 and make sure everything is setup correctly?  But I do think you need to make the time to do ascertain that you can do verify, rebuild backup etc - the file needs maintenance if its being used in multi user mode...
Photo of Data Rec

Data Rec, Employee

  • 8,178 Points 5k badge 2x thumb
This old post describes what may be causing the slowdown.
https://community.reckon.com/reckon/topics/host_multi_user_access_and_database_server_manager_dbsm

Guides on installing Reckon Accounts Business in the Multi user environment
https://kb.reckon.com.au/issue_view.asp?ID=5725

(Edited)
Photo of sheusz

sheusz

  • 120 Points 100 badge 2x thumb
Thanks for the reply. This is the first think I checked. Each user has been installed as Reckon Accounts Only. The software has been installed on the server as Company File Server only.

The DB is located on a file server. I have done a file verify and the file is good. Just on 1Gig in size.

Latest updates have been installed and still the issue remains.

Photo of Data Rec

Data Rec, Employee

  • 7,886 Points 5k badge 2x thumb

Try this on each computer that has Reckon Accounts software installed just to confirm that none are attempting to host. 

•  Open Reckon Accounts software.

 •  Go to the File menu, click Utilities, and then confirm whether you see


a) Host Multi-User Access.


b) Stop Hosting Multi-User Access


Is there any computer showing "Stop Hosting Multi-User Access"?




In-product help has useful information.

Click on the Help menu

Select Reckon Accounts Help

Click on the Search tab

Enter the key phrase Improve performance in multi-user mode


Regards,

Data Recovery Team



Photo of sheusz

sheusz

  • 120 Points 100 badge 2x thumb
As I said in my previous reply no users are hosting in multi user mode.