single touch payroll

KylieKylie Member Posts: 3
edited September 2019 in Accounts Hosted
When trying to upload my single touch payroll file in Reckon gov connect (under accounts hosted) I have the message employee 66 detail - email is not any of....  Are you able to help to prevent this error message.  (I have registered my software with the ATO)

Comments

  • RavRav Administrator Posts: 10,906 Administrator
    edited July 2018
    Hi Kylie,
    Is that the full error message?

    If not, can you post a screenshot showing the full message please (use the camera icon in the forum reply box)
  • KylieKylie Member Posts: 3
    edited September 2019
    Hi The error message is
    instance.employee data (66).detail. - Email is not any of [subschema0] [subschema1]
    The message deletes after a couple of seconds.  I have tried to print screen but will not let me.
    Thanks
  • John GJohn G Reckon Staff Posts: 2,283 ✭✭
    edited July 2018
    Hello Kylie,

    Such errors point to the full details required for the submission have not been provided.  Go back to the source of the information in your programme and complete the required fields.  

    Sometimes the correct format is important.  Check out this article for some items where exact matching and formats are important.  

    Hope this helps.


    regards,
    John
  • Robyn Kelly (Partner)Robyn Kelly (Partner) Accredited Partner Posts: 541 ✭✭
    edited July 2018
    Did you fix this Kylie?
  • Plaxy PierceyPlaxy Piercey Member Posts: 30
    edited July 2018
    I am having the same issue except mine comes up with 18 as the error number. I have gone through and checked all the details and they match. What else can I try?
  • RavRav Administrator Posts: 10,906 Administrator
    edited July 2018
    There is an employee in your list that does not have an email address or the email address field requires attention.

    Check the 19th employee in the list.
  • Plaxy PierceyPlaxy Piercey Member Posts: 30
    edited July 2018
    I have checked all employees emails and they are present and correct
  • Plaxy PierceyPlaxy Piercey Member Posts: 30
    edited July 2018
    It seems that one employee had two email adresses which caused the proiblem
  • KylieKylie Member Posts: 3
    edited July 2018
    Yes all solved thanks.  One employee had an incorrect email address.  
  • John GJohn G Reckon Staff Posts: 2,283 ✭✭
    edited July 2018
    Thanks Plaxy Piercey,
    That is the response we are getting from other users - STP can only tolerate one address in the email field.

    regards,
    John.
Sign In or Register to comment.