Help please with Payroll APP

marshlad
marshlad Member Posts: 19

Was wondering if someone could help me please I am desperate....... I am using the free app as we only have 1 employee...... I had used the old Reckon easily with no problems

BUT I now have a huge problem....... I have done 3 Payruns - September, December and March ( I only do a quarterly run of a few hundred dollars) ...... on the App it says that these runs are successful

BUT our accountant is saying that the runs show in ATO BUT there are no figures for the pay

On the APP if I go to the STP ( and I only discovered this today) it is as the accountant says there are no figures

WHAT am I doing wrong and how do I correct the past 3 submissions

Thanks in advance for any help and assistance given

Comments

  • Rav
    Rav Administrator Posts: 12,614 Community Manager Community Manager

    Hi @marshlad

    If you go into one of the STP tab and tap on one of these submissions does it show the submission type as 'Update'? (screenshot example below).

    If so, then you've been creating submissions as an Update Event ie. amending previous submission balances rather than sending them through as a new normal pay run.

    When you make an adjustment (also known as Update Events) and send it through it adjusts employee data only ie. there is no employer component to those update event submissions which is why it only shows that an entry has been received in the ATO Business Portal but doesn't show the detail ie. balances/figures.

    Employee data however on the other hand gets updated so when they login to their MyGov they'll see whatever was modified.


  • marshlad
    marshlad Member Posts: 19

    Hi Rav - no it is showing as ... TYPE - Pay run

  • marshlad
    marshlad Member Posts: 19

    Screen looks similiar to the one show

    Pay Date 30 September 2021

    No of Employees 1

    Total gross $0.00

    Total PAYG $0.00

    type pay run


    I have set up a "special earnings" of quarterly as we only pay quarterly and am thinking this is the problem as it is a set figure per quarter and not an hourly rate

    It is in other earning items

    earnings name name Quarterly Pay

    Super guarantee ticked

    Cant remember where it was but I do no have an input for hourly rate as that does not apply I just input the wage in the payrun

  • Rav
    Rav Administrator Posts: 12,614 Community Manager Community Manager

    Hmmm ok. So just to clarify, you've created this earnings item as an 'OTHER item' rather than an 'NORMAL' earnings item Usually the 'other earnings' items are intended for pay items that complement 'regular' pay rather than being a primary earnings item in itself. Admittedly, I haven't tested one of these pay items in a STP submission so I might need to check that over with our compliance officer but I'd say you've probably found the cause.


    In relation to quarterly payments, there's some deeper payroll functionality that is coming to the Payroll App very soon, its just going through final testing at the moment and that should give you more options. While this is more a stop-gap solution for use in the interim, an option could be to set the pay frequency to monthly, then use the relevant pay item to give the employee the base rate of their quarterly salary, and set the hours worked to '1'.

  • marshlad
    marshlad Member Posts: 19

    It was so easy to do in the "old" reckon.... never had a problem....... BUT I was looking at that and will give a try and see if it works......

    So to correct previous runs i would need to go back to each quarter and edit and then resend....

  • marshlad
    marshlad Member Posts: 19

    I am so confused now... where can I do those changes you suggested

  • marshlad
    marshlad Member Posts: 19

    I have got the employee details as monthly but h=where can I set the pay

  • Rav
    Rav Administrator Posts: 12,614 Community Manager Community Manager
    edited March 30

    If you want to create a custom earning item then follow the path below -

    Settings ➡️ Earning & Leave Items ➡️ Tap the + symbol ➡️ Add normal earning item ➡️ Create your custom earning item.


    Otherwise just use the 'Ordinary' earning item which is a 'normal' earning item.

  • marshlad
    marshlad Member Posts: 19

    Ok tried what you suggested and the figure is still $0.00

  • marshlad
    marshlad Member Posts: 19

    I tried Ordinary and tried adding a "special" neither of which worked ... still gives a $0.00 for the STP section

  • Rav
    Rav Administrator Posts: 12,614 Community Manager Community Manager

    Ok lets just hit pause for a second.

    Are the pay items you are using in the pay run for the employee(s) have the 'Tax Applicable' option ticked?

    This is on by default in the Ordinary earning item and in custom items can be manually set on or off.


    Secondly, when you're creating the pay run, you're hitting the + symbol and then 'New Pay Run' correct? (screenshot below)


    Finally, can you post a screenshot of how you've setup the pay run, the item setup and the STP submission where its showing 0.00 balances. Please censor any sensitive info such as names etc.


  • marshlad
    marshlad Member Posts: 19

    Here are the things you asked for… please let me know if you can fix this problem

  • Rav
    Rav Administrator Posts: 12,614 Community Manager Community Manager

    Hi @marshlad

    Thanks for the screenshots, unfortunately they don't show which earnings item and the setup of the item that you're using in that pay run but I've just went through a fair bit of testing and I've got to the bottom of it.

    As I mentioned in my previous reply this behavior is determined by the 'Tax Applicable' setting. This will determine whether or not the balances are reported or not. To put it simply, if the earnings item you are using has the 'Tax Applicable' ticked then it will be reported via STP. Conversely, if you've opted for the earnings item to not be applicable for tax then any balances associated with that item won't be reported for STP.


    To illustrate what I'm referring to see the two test examples below. (Click on the images itself for a larger view).


    Non tax applicable Earnings Item

    In the first screenshot you'll see that my earnings item does not have the 'Tax Applicable' option ticked.

    Then in the second screenshot I use this item in a pay run which records the balances in the PAY RUN (note: the pay run is separate to the STP submission.

    However when it comes to submitting this via STP it will show $0.00 as you'll see in the 3rd and final screenshot since the earning item isn't classed as tax applicable. This is the same result as what you are currently experiencing.


    Tax Applicable Earnings Item

    This second example is the converse of the one above. You'll see that in this one I have the 'Tax Applicable' setting ticked in the earning item setup and then I use the item in a pay run. Since that earnings item I am using is applicable for tax it gets reported to the ATO via the STP submission as you'll see in the last screenshot.

    Ultimately, this is what you need to do as I believe the earning item you're using in your pay runs do not have the 'tax applicable' option ticked and therefore the balances associated with that earning item in the pay run are not being sent via the STP submission (EXAMPLE 1). This isn't an issue but more a configuration setting that needs to be changed in the earnings item you're using in your pay runs. Once you do so, any pay runs that you create with that earnings item will show in the STP submission and be reported.

  • marshlad
    marshlad Member Posts: 19

    Thanks Rav...... will give this a go and let you know...... but while i have you here..... if this works as you said it should how do I go back and alter the previous submitted end of quarter submissions...... and thanks so much for your assistance

  • marshlad
    marshlad Member Posts: 19

    Actually i have worked out how to resubmitt - have done this BUT will need to see that everything is right once ATO has accepted the submissions.... will confirm everything is right once this is done..... thank you sooooooo much for your time and trouble looking into this matter for me ....

  • Rav
    Rav Administrator Posts: 12,614 Community Manager Community Manager

    No worries, I learned something myself by looking into this one so that's always good 😄😄.

    Hopefully its all good from here but let me know how you get on.