Problem with customer payment - it will not apply to an invoice when it should.

[Deleted User]
[Deleted User] Posts: 0
A customer payment has been entered for $10000 and applied against open invoices of exactly $10000. There are no short payments or overpayments. The amount of the payment matches the open invoice amounts perfectly in the payments screen. After saving, strangely, $10 shows as open on 1 invoice, and the payment of $10000 is showing that $10 is unapplied. We have tried deleting the payment and re-entering. We have tried opening the payment and typing the full open amount of the invoice in the payment screen and saving again. This doesn't help. The invoice still then shows as $10 unpaid and the payment transaction shows as $10 unapplied. Reporting is showing an open balance, it is not just in the customer transaction screen that this is showing.  Any ideas to fix?

Comments

  • Linda ABC
    Linda ABC Accredited Partner Posts: 1,131 Accredited Partner Accredited Partner
    edited June 2020
    Hi Fleur, can you show us a screen dump of the invoice?  what tax codes are being used on the various lines?  are there negative lines with negative tax amounts?  this is usually what causes this type of issue.
  • [Deleted User]
    [Deleted User] Posts: 0
    edited January 2019
    Hi Linda,

    Yes there are negative lines.

    Please see the screen dump below -



  • Linda ABC
    Linda ABC Accredited Partner Posts: 1,131 Accredited Partner Accredited Partner
    edited June 2020
    This will be the cause of the problem... first suggestion - re arrange the invoice so that the negative lines are after the positive lines - may or may not help?  But probably in the end you will need to put the negative lines on an Adjustment Note and leave the positive lines on the invoice - then apply the adjustment note to the invoice and that should resolve the problem... (you will need to reapply the payment)... cheers Linda
  • Kwikbooks (Professional Partner)
    Kwikbooks (Professional Partner) Member Posts: 823 ✭✭✭
    edited April 2020
    Linda is write there it may be the negatives, but it usually happens when a negative follows a different tax type.  say if the negative has gst and it follows a positive fre or inp.  Another user had the same issue last week, there is a knowledge base for this.

    I often do what you do without a problem and I see all yours have gst, when I do mine I start with the negative quantity.

    Are you running stock control?  You will need the negative quantity if you do.

    If Linda's suggestion doesn't work.....

    What effect has it had on the customer balance, does it show the $10.05 unpaid or paid?

    Can you see any payment in the customer that shows $10.05 open balance not applied?

    Can you do a screen shot of the cheque payment?
  • GlynisFNQ
    GlynisFNQ Member Posts: 26 ✭✭

    Goodness gracious! I've been on/off the Reckon helpline all day regarding this bizarre problem! 🤔 Almost went crazy over it...

    Should've known to come here to the Community first!! Very much appreciated finding this today!

    (Although I also do really appreciate the helpline!!)🤗

  • Robert_10860986
    Robert_10860986 Member Posts: 4

    Thank you for bumping this. I've seriously been trying to work this out myself on a couple of invoices that I raised and had negative quantities as mentioned above.

    I moved the negative line without GST to the top and it has cleared the annoying balance due.

    It has been driving me crazy.