I'm unable to Import bank data - AFTER resolving a similar problem (in a DIFFERENT COMPANY) yesterda

David Lee
David Lee Member Posts: 12
A RESOLVED problem re importing Bank Data to one Company, seems to have affected a DIFFERENT company. Why - and how to fix this?


  • David Lee
    David Lee Member Posts: 12
    edited February 2019
    The detail follows:

    ON Wednesday last week I had a problem when I realised I was importing data for the WRONG bank account into a set of accounts for Galaxy Trust. 

    'Shane'  posited a way to fix this a few days later but by then I had, with an external QBooks trainer,  resolved the problem  (for the Galaxy Trust accounts – see later comments) pretty much as Shane described except that after creating the account with the “_2” suffix, I imported the data to that account, then edited each transaction to shift it to the original account (without the “_2” suffix, then deleted the now empty “_2” suffix account. The trainer that I spoke to said that there had been problems with merging accounts in that previously entered bank transaction data was no longer visible. You may want to comment on that as the exact order of operations may be critical…




    I run 3 x sets of accounts on my copy of Reckon;  Galaxy, GLX & Starship. Yesterday I decided to import bank statement data for one of the non-Galaxy ones. I started with GLX. I created the ASB bank extract “.qif” files (being very careful to extract them from the correct account for this entity), and started the “Import Bank Statement” process as usual.  Please see the attached screen dumps. The first screen that comes up is (1) and I entered the data to that as you can see. On pressing <OK> to that, I got a little circular ‘something is happening’ icon then after that screen dump (2). And, according to screen dump (2) – no data has been imported.


    Now I make the point that this is (or at least should be) a completely different set of accounts from those for Galaxy Trust. However, my guess is that SOMEHOW the issue with the Galaxy accounts has affected the GLX accounts WRT THE DATES OF THE DATA BEING IMPORTED INTO GLX. I also note that the set of bank transactions that I incorrectly imported into Galaxy Trust is NOT a bank account for one of GLX or Starship (it was one of my wife’s personal accounts). I also make the point that the data extracted today for GLX’s Cheque account was for the period 19Oct-25Feb but that the ACTUAL bank data extracted was from 26Oct to 19Feb. [The comparative data for Galaxy for Galaxy’s last data imports (4 bank accounts) was an extract from 23Oct-18Feb and with the widest data range actually extracted being for Galaxy’s cheque account and being 25Oct to 15Feb]. I mention this to point out that the end data of both the extraction range AND the data actually extracted, was later for GLX then for Galaxy (so one might expect at least a few transactions to be visibly imported.)

      (I 'replied' to Shane's e-mail yesterday but now find that that doesn't go anywhere - why!!!! )

    Anyway, Today I tried to self-help myself again. 

    I found that I WAS able to import bank data into the third of the sets of accounts that I administer, Starship Trust. That all went as I'd expect it to - with a data range extracted from 23Oct18 to 26Feb19.

    So I returned to the GLX Investments set of accounts. However the problem persisted. i.e. I  selected the set of data to import (and the bank to import it into) and pressed [OK]. The little whirly-wheel Icon appeared then I was left with the screen that had originally undelain the 'Import' screen. No data had been imported.

    I then:

    a) Tried the method of fixing the issue as told to me by the trainer who'd helped with the previous problem. Didn't Work.

    b) I RESTORED the GLX data back to a backup I made on 19 Oct2019. I tried to import the data in the usual way. Didn't work.

    c) With that same set of (just restored) data, I then used the method as suggested by Shane to import the data. Didn't work.


    Can you advise:

    1. What’s happening and why?
    2. What I can do about it?
    3. Will this problem go on for ever (in one shape or form)
    4. WHY oh WHY can action on one set of accounts affect a different set of accounts?


    I’d also be interested in:

    1. Why, when I mistakenly imported data from my wife’s bank account last Wednesday, did Reckon not recognise that the bank account NUMBER as loaded against my Reckon GL bank account did NOT match the bank account number in the QIF file being imported and warn of the mismatch? Surely your programmers could/should perform this very simple check/warning.
    2. Given that there must be some (system held) data that says “data has been imported up to date X”, would it not be more efficient for you to let me know how I can access this date/dates and reset it back to what it should be? Can you let me know where this data is held and the correct tool to edit it?



    David Lee