Account not in account list

  • 1
  • Question
  • Updated 4 years ago
I am setting up a new company file in Reckon Accounts Premier 2015. I've exported all my lists from another company file and have imported them into the new file. I'm now setting up my opening balances journal and have been getting an error of "<account> is not in the account list" with a fixed asset subaccount. I've tried deleting the account and re-entering it but it doesn't seem to fix the problem. I've replicated the error with all asset and liability subaccounts, although it doesn't happen if it's a header account.

Photo of Katrina

Katrina

  • 200 Points 100 badge 2x thumb

Posted 4 years ago

  • 1
Katrina

I see you already have dollar content in the Credit field and I must assume you have just typed "At Cost"  into the Account field - which in turn prompts you with the "Account Not Found".     Just clarifying my understanding of the problem.

And you mention there is some distinction between the 'account' being a sub-account (or not),  IE  The top level, you call a 'header account',    and that  "At Cost"  whilst appearing justified to the left (as if a header account),  you believe it already exists...

It would be interesting to see a screen capture of the Chart Of Accounts to illustrate why you believe "At Cost" exists as a 'header account'.     Can you provide that for us to help further?  (just a snippet of a few lines to satisfy some privacy.)


Cheers


Gary Pope
An Accredited Partner- Consultant  (VIC. Aust)
http://www.alchester.com.au/reckon-accounts-clarified/
"Working with Accountants/Bookkeepers PPs/APs, as an
      independent IT Professional
and retired FCPA Accountant"
(Edited)
Photo of John Graetz

John Graetz

  • 23,890 Points 20k badge 2x thumb
Hi Katrina.  This sounds really weird.  The only circumstance that I am aware of, where an account does not show, is if somehow it has been marked as inactive.  You could have a look at this:
1.  At the bottom of your list of your Chart of Account you should find three tabs - "Account", "Activities" and "Reports" and potentially to the right of that a small box for "Include Inactive".  Is there a tick in that box?  If not, tick it.  If you don't see the box, go instead to the left to the tab "Account" and click on the down arrow.  On the list, is there a tick against "Hide Inactive Accounts"?  If there is, untick it.  I hope that this provides the solution for you.  John G.
Hi Katrina

I am with Gary, the account "at cost" is not set up, need to see your whole chart of accounts, also this screenshot appears to be whited out for part of the account  name and debit column.

If you are trying to set up assets, then it is asset header - sub acct: plant at cost & depreciation.

I.e  Backhoe 550D
            Backhoe 550D at cost
            less accum. depreciation

      Hi-lux ute 2012
            Hi-Lux ute 2012 at cost
            less accum. depreciation

and so on.... there is no simply "at cost" account
Photo of Katrina

Katrina

  • 200 Points 100 badge 2x thumb
Hi Gary and Kim

I have imported the Chart of Accounts from an old file, so my gut feeling is that there's something gone weird with the import. The accounts exist in the Chart of Accounts (see screenshot) but if I open up the drop down list to select the subaccount of the fixed asset account (in this case, "At Cost"), I then get the error message "<account> is not in the Account List."

Gary: sorry, I think you misunderstood or I wasn't clear about 'subaccount' or 'header account.' What I meant was if I selected, for example, "Computer & Office Equip" then I wouldn't get the error message; but if I select any subaccount of any asset or liability account (eg, in this case, "At Cost") then I get an error telling me the account doesn't exist.

Kim: I obscured some of the text in my screenshot for privacy reasons. It's not relevant to the problem.

John: The accounts are not inactive, I believe if they were I would get a message asking if I wanted to make them inactive.

Cheers

Katrina
Katrine.  mystery....  

So, the usual way to diagnose a problem is to see if you can MOVE the problem, so that you know you're biting away at the right end of the problem, so to speak.

I'd suggest, as a TEST,  that you rename one of those "At Cost" items  to say:  "At Cost (COmputer & Office Equip)"    and try your original transaction to see if it 'picks' the item.

That might help separate all the mystery about it existing, being active and so forth,  and perhaps there is some confusion about having multiple 'sub-accounts' with same name.   I know they should be part of the header account,  bnut when there are 'same name' type sub accounts I recall needing to start TYPING like this:

"Comput"      (might start to bring up the header desired, and then)   ":"   (to start seeking out the sub-account, then)   "At C..."    (should find it).

OR:
Start typing:   "At Cost (Co..."    should find it in one go as a header:sub-account   becuase it is now UNIQUE.

See if that throws any light on this problem

Gary Pope
An Accredited Partner- Consultant  (VIC. Aust)
http://www.alchester.com.au/reckon-accounts-clarified/
"Working with Accountants/Bookkeepers PPs/APs, as an
      independent IT Professional
and retired FCPA Accountant"
Photo of Katrina

Katrina

  • 200 Points 100 badge 2x thumb
Hi Gary

I have just tried that and it hasn't made any difference. I also tried setting up a "Test Account" asset account and giving it some subaccounts, and I got the same error with the subaccounts there too. 

At this point, I've decided to not bother setting up this new file until next year, so the problem is academic. I'll probably manually set up the Chart of Accounts from scratch in my spare time over the next 12 months, hopefully that'll get around the problem.

Cheers

Katrina
Photo of John Graetz

John Graetz

  • 23,890 Points 20k badge 2x thumb
Hi Katrina.  I take it that you have the Chart of Accounts open and that it is within this window that you cannot select the account.  

1. Have you tried to actually record, say a dummy transaction to the account - possibly the same result?
2.  Have you right clicked on the item and selected "edit"?  perhaps the same result.
3.  You could go to the potential fall-back, fix most things option, by doing a rebuild, say at least three times, and see if that fixes things.
John G
Photo of Katrina

Katrina

  • 200 Points 100 badge 2x thumb
Tried it, three times, it hasn't fixed it.
Photo of John Graetz

John Graetz

  • 23,890 Points 20k badge 2x thumb
Well at least we know that won't work - crazy mystery this one!  John G
Katrina/John

We're all still curious, unfortunately it can be contagious!   The fact that Katrina (sorry about wrong spelling earlier!  - type too fast without looking! - bad fault, along with long comments....)  even tried a manually created new test ASSET and that had the same issue,  I'm thinking something is corrupted somewhere in all this.  IN an earlier PST,  Katriona said that she does NOT get the error if selecting the TOP header name in her desired JOURNAL:  ie:  "Computer & Office Equip"  can be selected (WORKS).  

SO it points to something COMMON to all/any sort of SUB-account.

I wonder if the choice of 'preferences' has any bearing like:
edit -->  Preferences --> Accounting -->  Company Preferences .....

- use accounts numbers
- require accounts
- show lowest account only

Perhaps allocate an account number to one of the little groups under test,  adn change a preference and see if the BEHAVIOUR changes?

Gary
(Edited)
Photo of Katrina

Katrina

  • 200 Points 100 badge 2x thumb
Well, would you look at that?!


I changed the preference to "Use Account Numbers" and all of a sudden it works.

So I went back and unticked "Use Account Numbers" (so it was back to how it was originally) and it still works.

Thanks for your help! This has been very weird.
(Edited)
Photo of John Graetz

John Graetz

  • 23,890 Points 20k badge 2x thumb
Great work Gary and Katrina.  Another happy "vegemite" even though it tested everybody to the limit!!    This now needs to become a Knowledge Base item.  John G