Quicken 2008 backups have no Quicken icon and do not restore, even in 2013

  • 3
  • Problem
  • Updated 6 years ago
  • Acknowledged
  • (Edited)
After using Quicken 2008 for years about 6 mth ago I found my backup files had no Quicken icon and would not restore files. I have upgraded to Reckon 2013 but the problem persists and I am still unable to backup useable files?
Photo of Keith Tier

Keith Tier

  • 120 Points 100 badge 2x thumb

Posted 6 years ago

  • 3
Photo of Ifti

Ifti, Product Owner

  • 6,616 Points 5k badge 2x thumb
Hi Keith,

Thank you for your post.

If there is no icon next to a file, it might point to an invalid or no program association for that file extension. 

Try this:

(Windows 7):


  1. Go to Control Panel > from top right, change View by to Category
  2. Click on Programs > under Default Programs, click Make a file type always open in a specific program and wait until the list loads (may take few minutes)
  3. Look for .qdf and double click on it 
  4. In Open With window, select ReckonAccounts Launcher (2013) or Quicken Launcher (older than 2013) if present, otherwise Browse to C:\Program Files (x86)* \Quicken\  and select qw.exe and Click Open

    * (for 64-bit OS, for 32-bit, it'll be under Program Files or if you have changed the installation folder, choose that)

  5. Click OK again to save and close Control Panel
This should show an icon next to .QDF file(s). Normal backup files have .QDF as extension and when older Quicken product backs up, it actually copies all the files. However, from Reckon Accounts 2013, there's a new option to compress files to a single file and it's got a new extension .rkn


I would suggest you to try below:

  1. Create a folder in your Desktop or C drive called "Reckon Data files"
  2. Go to your old version and make a new backup and save it to the folder in step 1
  3. Now open up Reckon Accounts 2013 and restore file from that folder and save it to a new location (to differentiate any previous files)

I hope above helps you to resolve your issue. 

Thanks

Ifti

Photo of Keith Tier

Keith Tier

  • 120 Points 100 badge 2x thumb
This problem has certainly NOT BEEN SOLVED. My 20 year love / hate relationship with Quicken/Reckon continues. I love the product and hate the support - or lack of it! Just purchased the new Reckon 2013 - and now told I have to pay $4.90 a minute on the phone to get it to work? Not likely. Time to look for a new accounting software that support their customers!
Photo of Ifti

Ifti, Product Owner

  • 6,616 Points 5k badge 2x thumb
Hi Keith,

Can you please send your Customer ID and contact number to community@reckon.com.au and I will investigate it further.

Thanks

Ifti
Photo of Ifti

Ifti, Product Owner

  • 6,616 Points 5k badge 2x thumb
Hi Keith,

Let's try this:

Rename your data file:
  1. Go to File > File Operations > Rename > Single click or hover over to the file to get it selected. 
  2. At the bottom where it asks for New Name For File, type in a new file name and keep it very simple and have 4-5 characters name without any special characters and/or space. Example: mydata.QDF
  3. Create a new folder in your C drive and give it a name like Data Files
  4. Go back to Reckon Accounts and save a backup copy (either .rkn or normal backup) to that folder (step 2) and see if it backs up and if you can restore
If above fails, try below:

Validate and Super Validate your file to try fixing any issues inside the data file:
  1. Go to File > File Operations > Validate > select on your data file > OK. Wait until it finishes
  2. Do a Super Validation by going to File > File Operations > now press and hold Ctrl and Shift keys on your keyboard and keep on holding and Click Validate > select your File and click OK > now you can release those keys and wait until it finishes
  3. Try backing up again and see if you can restore

Let me know how that goes.

Cheers,

Ifti
Photo of Keith Tier

Keith Tier

  • 120 Points 100 badge 2x thumb
Well battling on with the problem. The icon-less backup files are not visable to reckon, so they can't be validated. Trying the new file name has sorted out why Reckon was unable to backup to new folders. The file names were too long and Reckon would lockup. I had to use Task Manage to shut reckon down and start again. Why the file name grows by many digets everytime you use it has me bluffed. especially when you have been using it for years. Although I have found I can copy the current file and paste it to another location to give me a backup of a file, the Reckon "Backup" system is still of no use saving only icon-less files that are unusable.

Keith.
Photo of Ifti

Ifti, Product Owner

  • 6,616 Points 5k badge 2x thumb
Hi Keith,

Thank you for informing that renaming helped you.

We have seen this before that doing this fixes most backup issues. We have few articles about it in our Knowledge Browser too. 
http://www.quicken.com.au/kb/search.asp?cate=16&search=backup&type=3&mode=search

For file naming problem, you may want try look into the Preferences to see if that helps:
Go to Edit > Preferences > Program> Backup > un-tick "Add the date to the file name" option.

Although when you create .rkn file and there's no icon next to it, it's still OK to restore that file.

To restore, do the following:
 
  1. File > Restore backup file > Restore backup... > Local Backup >  OK > browse and select your backup file > OK > Select a location to restore the file 
  2. After restore is completed, go through File > Open > browse to above location and select your file to open.

Thanks

Ifti 
Photo of Kevin Chamberlain

Kevin Chamberlain

  • 418 Points 250 badge 2x thumb
I can totally sympathize with you. Recon needs some serious competition. I for one would be out in a flash.
Photo of Inigo

Inigo

  • 6,320 Points 5k badge 2x thumb
There are surely other personal finance packages available in the market and it would be up to the user to seek out the best solution for their needs.

Note that not all users pay attention to the resulting file name and how it gets larger, or how such a file name length in conjunction with the folder path can be problematic.

In saying that, the issue with the file name getting larger because the user has ticked the option to add the "Add the date to the file name" to the backup name should be fixed up and does not appear to be a complex problem.

A simple check by the 'backup function' to test for how long the file name is and if it exceeds say 250 characters, should either prompt the user to change the name or rename the file totally, keeping the actual file name and adding only the last 'date' to the file name.

Example:

File name is "Kevin's File.QDF" 


What it currently does:

After first backup, with the date added becomes "Kevin's File (01-12-2013).RKN"
After second backup, with the date added becomes "Kevin's File (01-12-2013) (07-12-2013).RKN"
After third backup, with the date added becomes "Kevin's File (01-12-2013) (07-12-2013) (14-12-2013).RKN"
After fourth backup, with the date added becomes "Kevin's File (01-12-2013) (07-12-2013) (14-12-2013) (21-12-2013).RKN"

The old dates should NOT keep being retained in the new backup file name


What it should actually do:

After first backup, with the date added becomes "Kevin's File (01-12-2013).RKN"
After second backup, with the date added becomes "Kevin's File (07-12-2013).RKN"
After third backup, with the date added becomes "Kevin's File (14-12-2013).RKN"
After fourth backup, with the date added becomes "Kevin's File (21-12-2013).RKN"


Only the new dates should appended to the new backup file name.

-IM
Photo of Ifti

Ifti, Product Owner

  • 6,616 Points 5k badge 2x thumb
Hi Inigo,

Thank you for the detailed info. I surely will report it to the developers.

Cheers.

Ifti
Photo of Richard Humfrey

Richard Humfrey

  • 102 Points 100 badge 2x thumb
No wonder Reckon want to use their  own caused Reckon problem to make $4.90 /per min and are either not prepared to help or update their program and so far I have not managed to get these RKN restore solutions working....gets frustrating when I am getting further and further behind with  restoring 12 months backups.....why can't the developers get it fixed.......it worries  me -always thought Reckon was a good product until now.

Richard
Photo of John G

John G, Information Support Analyst

  • 27,530 Points 20k badge 2x thumb
Official Response
Thanks to all contributors on this issue.

Just to sum up the situation here.  When you restore a backup with a date attached, the restored file has the name of the backup – that is, the original file name and the date of the backup.  

When you create a backup the new date is added.  If you restore that backup with two dates, then your file has two dates attached.  Backup that file and a third date is attached.  

And so it goes on.

I can understand the confusion leaving the date on the restored file eventually causes users.  This issue has been reported to our Developers who will address it in their normal course of updates.  

In the meantime you have two options.

Firstly, when restoring a backup with a date attached, rename the file with the date removed, rename the file through File > File Operations > Rename. 

Please restrict the name to 8 characters. Note that in renaming you will over-write any existing files with the same name.  then validate the renamed file.  

Secondly, backup without dates.  change your preferences at Edit > Preferences > Setup > Backup > and untick the option: Add the date to file name (QDATA_20080804).

Thanks everyone for your contributions – they are appreciated.  

I am closing this thread.  

regards,
John

This conversation is no longer open for comments or replies.