What is the maximum number of Employees can i add per pay run? 10?

  • 1
  • Question
  • Updated 1 month ago
I had just added my 10th employee in this pay run and now there isn't an option/Add button to add another employee. Is 10 the limit? I only have 1 more to add. Do I have to create a new separate pay run now just for that 1 employee?
Photo of Shane Saad

Shane Saad

  • 140 Points 100 badge 2x thumb

Posted 1 month ago

  • 1
Photo of Ken Lee

Ken Lee

  • 230 Points 100 badge 2x thumb
I have processed up to 18 employees before without a problem. I have not read of any limit. You may want to take note of the number of records u can view. By default, you can view 10 recorded. You can change this by clicking on the drop down menu to 20 or 50 in some screens
Photo of Shane Saad

Shane Saad

  • 140 Points 100 badge 2x thumb
Hi Ken, thanks for the reply however there's no option on the page to change the view number. Very weird. Any other suggestions?
Photo of Ken Lee

Ken Lee

  • 230 Points 100 badge 2x thumb
U r right, Shane... no drop down view. I do not add payroll manually. I set a standard pay for every employee in Employees/Pay Setup. When you create a new scheduled pay run, a record is created for every employee that has a pay setup record. You can edit each record if the hours are different or delete the record if there's no pay for that period. Note:it must be a scheduled pay run for this to work. All the best.
Photo of Shane Saad

Shane Saad

  • 140 Points 100 badge 2x thumb
Hi Ken, I called tech support and got through after an hour waiting (not bad, I waited 1.5hrs the other day lol).

Solution: Delete the last employee, then add the other employees, then add the last employee from the drop-down list last. It's weird that if you select the last employee it will not allow you to add any more employees. It must be done in this order only.
Photo of Ken Lee

Ken Lee

  • 230 Points 100 badge 2x thumb
Shane... thanks for the update. Good to know. Couldn't have picked up this error. Always done my payroll in sequential order. Surely this is a bug!