Server 2016 install

Brett LemonBrett Lemon Member Posts: 1
Installing Reckon Accounts Premier 2018.
I installed the server only option straight onto the server, all went fine. Moved the file to the system, and scanned the drive, and opened up the file from a remote client. the file now pops up and tells me I can't do multi-user mode. I need to tell it that from the server. meaning I now have to install the the full software. Bit crude, but OK.. Now when I try install, the the full option or the client only option. it seems to get past installing the payment system, and it then immediately pops up with "Installation Interrupted". 
I thought.. Oh, fun..
I will uninstall it, and run again.. When I try to uninstall anything, it tells me it can't find it to uninstall..

Can anyone shed light on this..

Thanks all..


  • ShisirShisir Reckon Staff Posts: 257
    edited September 2018
    Hi Brent

    Sorry to hear that.

    Can you please try this instruction


  • David MoylanDavid Moylan Member Posts: 2
    edited October 2018
    i have experienced this exact same issue. originally the server was 2008r2 and we've just upgraded to server 2016 and it's all gone downhill.

    i have performed many installs of reckon for many different clients and i'm fully aware of firewalling and port requirements and folder permissions for the service account and how the whole reckon server/workstation stuff works.

    but i have experienced the exact same problem as Brett has - once the database manager is setup correctly and scanned the files, i can't go multi user from the workstation.

    of most interesting note - is that i *don't* see any of the port 10181 traffic at the server end.

    if i do a: netstat -ano | find "10181"
    at the workstation end, i can see it making connections to the server in state "TIME_WAIT"
    at the server end, i can only see port 10181 listening with no connections.

    if i manually telnet from the workstation to port 10181 on the server, the connection is accepted and both the workstation and server show a port 10181 connection.

    initially this might make one think the problem is workstation based, however i haven't changed any workstations - just the server where the reckon files are being hosted. it used to be a windows 2008r2 server (and worked perfectly last week) but since we've upgraded this to server 2016, the reckon accounts database server manager doesn't appear to be doing anything.

    i just double checked that i have .NET 3.5 installed on the server and it is.

    i've added all firewall exceptions at the server end (and i know it's working because i can telnet to the port from the workstation). firewalling has been disabled on both the server and workstation but this has made no difference. i have no antivirus or security software on the server end. i run webroot on the workstation end, but this configuration has not changed in years.

    this has to be an issue at the server end, but i can't currently work out what the issue is.

    this installation is reckon accounts enterprise 2018.

    i did spend over one hour on the phone to reckon support, and they were, frankly, useless. the person supporting me clearly had no idea about the database server manager and how it worked. his solution was to move the database file to a workstation and share it from there.

    my gut feeling is that something in the server 2016 security infrastructure is blocking the communication.

    if anyone discovers anything useful i think we would all love to hear about it.

    cheers, Wiz!!

  • David MoylanDavid Moylan Member Posts: 2
    edited October 2018
    i managed to resolve this ... the issue was related to a parameter in the QuickBooksDB27 service.

    since we were decomissioning the 2008R2 server and replacing it with a 2016 server, we originally built the new 2016 server prior to changeover so we could robocopy all the data across. the reckon database manager was installed at this time.

    at the time of cutover, we renamed the current server (i'll call it BLAH-FS1) to OLDBLAH-FS1. we the renamed the new 2016 server to BLAH-FS1. this ensured all UNC paths would remain valid.

    if you look in the registry under:
    HKEY_LOCAL_MACIHNE\CurrentControlSet\Services\QuickBooksDB27\Parameters you'll see a REG_SZ called "Parameters" which contains the command line switches for the database service. in my case, it looked like:

    -n QB_NEWBLAH-FS1_27 ...

    i changed this to:

    -n QB_BLAH-FS1_27 ...

    and restarted the database service and rescanned the reckon folder. immediately everything started working as expected.

    i could then see port 10181 connections coming in from the workstations.

    it appears that originally the workstations were connecting in, but the connections were being rejected. i assume that the database service itself used it's own name as a connection reference. a bit strange, however it resolved the issue.

    so in summary, if you have built a server, installed reckon database manager and then renamed the server name, this is why the database manager doesn't appear to work.

    Brett - unsure if this matches your scenario at all, but if not then i would recommend uninstalling the database manager and then ensure that this registry key gets removed manually prior to reinstalling. You shouldn't need to install Reckon itself - only the database manager is required.

    cheers, Wiz!!

  • LuckyLucky Member Posts: 1
    edited April 2019
    Hey David,

    Good Day Mate, Hope you are doing well.

    I am asked to do the same upgrade and I never dealt with these kinds of the upgrade.
    Would you mind if you can send all the steps when you migrated all the data from 2008 r2 to 2016 server?

    The software we have on the server:-  
    1- reckon Accounts payment service requirements
    2-Reckon accounts premier edition 2017
    3- Reckon accounts premier edition 2018
    4- Reckon account premier: Professional service edition 2016


Sign In or Register to comment.