Welcome to the brand new Reckon Community!

For some tips on getting started check out the 'About Reckon Community' section

I'm unable to import bank data and need help. I've written an e-mail setting out the situation. What

David LeeDavid Lee Member Posts: 12
edited February 13 in Accounts Personal Range
I'm unable to import bank data and need help with that. I've prepared a detailed e-mail setting out the situation. What e-mail address can I send it to?


  • RavRav Administrator Posts: 10,747 Administrator
    edited February 2019
    Just post the outline of the situation on the forum here and we'll get the right people on the case.
  • David LeeDavid Lee Member Posts: 12
    edited February 2019

    Please refer to the attached Word Doc with 4 screen shots. That follow this TXT post.


    The problem:

    I go through the usual process of importing a QIF data file extracted from ASB, screen shots 1-3 but at the end of the process (screen shot 4), there is no data in the file named “ASB 50 Fastsaver”. Interesting though, on that yellow highlighted line, it says “- no transactions received on 14/02/19”. I mention this as the data I was trying to import was for the date range 23/10/18 to 18/02/19 but the data ACTUALLY IN that range ran from 26/10/18 to 14/02/19. i.e. the system seems to have accessed the data file (to get the 14/02/19 date), just not ‘actioned’ the import.



    I have run this process many times before without problems. However, yesterday (prior to the above mentioned problem) I extracted bank data from the wrong bank account (another ASB one with a 050 suffix). I ran through the process of screen shots 1-4 without any technical problem and the (wrong) data was correctly imported. I then started importing this data, line by line, into my General Ledger. After 11 transactions (bank interest, RWT and Fees) I realised that I had the wrong data.


    To correct the situation:

    ·       I went  into my Balance Sheet report, clicked on the “ASB 50 FastSaver” account and bought up “Transactions by Account”. I then selected the 11 that I’d just imported, on at a time, clicked on each and when the detail came up, used the Edit Menu option to “Delete Deposit” or “Delete Cheque” as appropriate (and said Yes to the confirm option).

    ·       I then went to the “Online Banking Centre” (as per screen shot 4), selected/highlighted the line “”ASB 50 Fastsaver” and clicked on the [Delete] button to its right. This deleted the “ASB 50 Fastsaver” line.

    ·       At this point I assumed that I’d fixed my operational error, went back, and imported the CORRECT 050 bank account’s data and the process worked as per usual, EXCEPT, as explained above, the actual data is not being imported.



    What can I do to actually import the data?
  • David LeeDavid Lee Member Posts: 12
    edited February 2019

  • David LeeDavid Lee Member Posts: 12
    edited February 2019

  • David LeeDavid Lee Member Posts: 12
    edited February 2019

  • David LeeDavid Lee Member Posts: 12
    edited February 2019

  • ShaneShane Reckon Staff Posts: 560
    edited February 13
    Hi David,

    Thanks for the detailed information, its very helpful to understand what has gone wrong, and I have come across this many times.  The reason it says "no transactions received on 14/02/19" is because for some reason Reckon Accounts doesn't allow you to import the same date range twice.  But the solution is not to difficult.

    1. Start by backing up your company file, saving it to a location that is easy for you to find later if needed.
    2. Next go to your chart of accounts, edit the bank account you are trying to import into and take note of the details, such as BSB, Account number, etc as you will need to re-enter these at a later stage.  Un-tick the box to enable online banking on the Online Banking tab.
    3. Create a new bank account with the exact same name as the original bank account, but with "_2" at the end of the name (eg: ASB 50 Fastsaver_2).  Don't worry about any details other than the name at this point.  Save and close. 
    4. Edit the original bank account again (ASB 50 Fastsaver) and add _2 to the end of its name (so now its also called ASB 50 Fastsaver_2).  Save and close.  It will tell you an account with that name already exists and ask if you want to merge them.  Select the option to merge them.
    5. At this point the merging of the original accounts transactions into the new account will begin.  It may freeze and say not responding, but don't worry this is normal.  And it may take a while to complete.  Just leave it to do its thing for however long it takes (could be 5 mins, could be 2 hours). You will know its complete when you are back to the chart of accounts and you can click on things again.
    6. When complete you will have only one ASB 50 Fastsaver_2 account.  Edit the bank account, remove _2 from the name.  Go to the online banking tab, tick the box to enable online banking and complete the fields as they were in the original bank account.
    7. You can now try importing your bank statement again, and if everything goes as expected you should have success.  

    Hopefully this should fix the problem.  As I mentioned, I have come across this many times, and it should fix the problem.  If anything does go wrong, please restore the back up you made at the start and try going through the process again.  Please let us know how you get on.

  • David LeeDavid Lee Member Posts: 12
    edited February 2019

    Hope that you get this (I’ve loaded the same via the on-line portal…)


    The detail follows:

    ON Wednesday last week I had a problem when I realised I was importing data for the WRONG bank account into a set of accounts for Galaxy Trust. 

    'Shane'  posited a way to fix this a few days later but by then I had, with an external QBooks trainer,  resolved the problem  (for the Galaxy Trust accounts – see later comments) pretty much as Shane described except that after creating the account with the “_2” suffix, I imported the data to that account, then edited each transaction to shift it to the original account (without the “_2” suffix, then deleted the now empty “_2” suffix account. The trainer that I spoke to said that there had been problems with merging accounts in that previously entered bank transaction data was no longer visible. You may want to comment on that as the exact order of operations may be critical…


     I run 3 x sets of accounts on my copy of Reckon;  Galaxy, GLX & Starship. Yesterday I decided to import bank statement data for one of the non-Galaxy ones. I started with GLX. I created the ASB bank extract “.qif” files (being very careful to extract them from the correct account for this entity), and started the “Import Bank Statement” process as usual.  Please see the attached screen dumps. The first screen that comes up is (1) and I entered the data to that as you can see. On pressing <OK> to that, I got a little circular ‘something is happening’ icon then after that screen dump (2). And, according to screen dump (2) – no data has been imported.

     Now I make the point that this is (or at least should be) a completely different set of accounts from those for Galaxy Trust. However, my guess is that SOMEHOW the issue with the Galaxy accounts has affected the GLX accounts WRT THE DATES OF THE DATA BEING IMPORTED INTO GLX. I also note that the set of bank transactions that I incorrectly imported into Galaxy Trust is NOT a bank account for one of GLX or Starship (it was one of my wife’s personal accounts). I also make the point that the data extracted today for GLX’s Cheque account was for the period 19Oct-25Feb but that the ACTUAL bank data extracted was from 26Oct to 19Feb. [The comparative data for Galaxy for Galaxy’s last data imports (4 bank accounts) was an extract from 23Oct-18Feb and with the widest data range actually extracted being for Galaxy’s cheque account and being 25Oct to 15Feb]. I mention this to point out that the end data of both the extraction range AND the data actually extracted, was later for GLX then for Galaxy (so one might expect at least a few transactions to be visibly imported.)

      (I 'replied' to Shane's e-mail yesterday but now find that that doesn't go anywhere - why!!!! )


    Anyway, Today I tried to self-help myself again. 

    I found that I WAS able to import bank data into the third of the sets of accounts that I administer, Starship Trust. That all went as I'd expect it to - with a data range extracted from 23Oct18 to 26Feb19.

    So I returned to the GLX Investments set of accounts. However the problem persisted. i.e. I  selected the set of data to import (and the bank to import it into) and pressed [OK]. The little whirly-wheel Icon appeared then I was left with the screen that had originally undelain the 'Import' screen. No data had been imported.


    I then:

    a) Tried the method of fixing the issue as told to me by the trainer who'd helped with the previous problem. Didn't Work.

    b) I RESTORED the GLX data back to a backup I made on 19 Oct2018 ( said 2019 earlier – clearly not possible). I tried to import the data in the usual way. Didn't work.

    c) With that same set of (just restored) data, I then used the method as suggested by Shane to import the data. Didn't work.


    Can you advise:

    1. What’s happening and why?
    2. What I can do about it?
    3. Will this problem go on for ever (in one shape or form)


    I’d also be interested in:

    1. Why, when I mistakenly imported data from my wife’s bank account last Wednesday, did Reckon not recognise that the bank account NUMBER as loaded against my Reckon GL bank account did NOT match the bank account number in the QIF file being imported and warn of the mismatch? Surely your programmers could/should perform this very simple check/warning.
    2. Given that there must be some (system held) data that says “data has been imported up to date X”, would it not be more efficient for you to let me know how I can access this date/dates and reset it back to what it should be? Can you let me know where this data is held and the correct tool to edit it?



    David Lee
  • David LeeDavid Lee Member Posts: 12
    edited February 2019
    BTW: AFTER all the above I then AGAIN restored the GLX database back to 19 October 2018 and used the "Shane" method EXPLICITLY as stated to try to import the data to one of the accounts (th Fastsaver one). Again - it didn't work.

    Can you help?

    David Lee

  • David LeeDavid Lee Member Posts: 12
    edited February 2019
    Hi Shane etc,

    The Trainer that I'd previously got help from asked: 

    Have you deleted / moved / archived the 1st copy of qif files you downloaded and deleted the qbo files?"

    To which I replied:

    "I re restored the GLX data and re recreated the .qif files IN A DIFFERENT folder. I then imported them…. And it WORKED!!!"


     Which is great!  But...

    Final Comments:
    While I'm very grateful for my Trainer's insights and help (and Shane's I do add), I have to say that this sort of trickery-pokery shouldn't be required to solve these sorts of issues (and they shouldn't have arisen in the first place). The system should work!! 

    It should check that bank data being imported is being imported to the correct GL account. 

    After a set of accounts has been restored, it should be AS IT WAS in all respects.

    If bank statements are imported, then any temporary files used in that process should be pre-deleted (by the Reckon software) and then recreated. 

    ALL of the above are pretty basic/standard programming processes. 

    Will Reckon attend to these?? 

Sign In or Register to comment.