Leave Balances have not updated in employee records ONLY, pay slips & leave report is correct?

I did a pay run yesterday, the leave balances on ALL pay slips and the leave balances report are ALL correct, but I noticed in the employee records the leave balances have not updated by this pay run, is there a delay in the employee records updating?

This is the 3rd pay run since migrating from Payroll Premier, not sure why the balances have not updated in the employee records only after this pay run when the pay slips are correct? This is a sample below of one employee.

Pay run status is PAID - the ABA file has been created and paid. The only thing not done with this pay run is the upload STP declaration. Thank you - Gayle




Answers

  • Rav
    Rav Administrator, Reckon Staff Posts: 15,092 Community Manager Community Manager

    Hi @Gayle_10863666

    Can I just clarify, did the leave balances update after the previous payruns that you created since making the move over to Reckon Payroll? OR have the leave balances in the employee profile not updated at all from any of the 3 pay runs you've created?

    Do you have more than one annual leave item setup? You can check this in Settings ➡️ Pay Items ➡️ Leave



    Lastly, what is the configuration of your annual leave item?

    You can find this by going into the Annual Leave item itself, example screenshot on the left.

  • Lucas
    Lucas Reckon Staff Posts: 62 Reckon Staff

    Hi @Gayle_10863666,

    As Rav has stated above, if you have an employee's profile that has not updated the leave balances from any of the last 3 pay-runs.

    Could you please tick the 'Include in time worked leave accruals.' for each earnings item in the pay-run:


    That should adjust the balances after reverting the previous 3 pay-runs as draft and marking again as paid.

    Thank you and have a lovely day.


    Cheers,

    Lucas

  • Gayle_10863666
    Gayle_10863666 Member Posts: 32

    Hello Rav

    The previous 2 pay runs have updated correctly, the balances in the employee records are only out by the pay run that was run yesterday, (pay slips & leave report are correct).

    I only have one annual leave set up.

    All employees leave is set up to accrue PER PAY - this shot below is the same employee in the first post, which are out by the accrual rate per pay after yesterday's pay run (as are all employees)

    I have been trying to think if I have changed anything since last pay run, but can't really recall. Weird though that pay slips and leave report are correct.

  • Rav
    Rav Administrator, Reckon Staff Posts: 15,092 Community Manager Community Manager

    Thanks @Gayle_10863666

    Yes its pretty odd that the report and payslip are correct whereas the employee profile section has a variance. When you check the setup of your earning item, is the 'Include in time worked leave accruals' ticked or unticked as per the info from @Lucas above?


    I've flicked through an access request to your book, can you please take a look and grant access when you have a sec.

    This is going to sound a bit silly but I'd like to just monitor this for a day. I noticed that the pay date for the pay run is today (24 October), I just want to see if the employee profile updates after the pay date passes ie. tomorrow. Its a bit of a far fetched guess on my part at this stage but just want to see if that has any thing here.

  • Gayle_10863666
    Gayle_10863666 Member Posts: 32

    Rav, I am not familiar with the access request, where do I find that to give you access.

  • Rav
    Rav Administrator, Reckon Staff Posts: 15,092 Community Manager Community Manager

    It would have come through via an automated email to the email address your Reckon Payroll book is registered under.

    That looks to be the same email address that your Reckon Community account is registered under as well.

  • Gayle_10863666
    Gayle_10863666 Member Posts: 32

    Thank you - granted - Regards Gayle

  • Gayle_10863666
    Gayle_10863666 Member Posts: 32

    Rav, I have deleted the Bank Payment and was going to change it back to Draft to run Paid again, everything did look OK re Lucas' suggestion, but I will wait until I hear back from you before doing this, I won't do anything until then. Thank you - Gayle

  • Rav
    Rav Administrator, Reckon Staff Posts: 15,092 Community Manager Community Manager

    Thanks for granting access @Gayle_10863666.

    I've just taken a quick look and its a bit odd.. when I view the profile of the specific employee, the leave balances are appearing as below 👇


    The other areas ie. payslip and Leave Balance Report, also match the balances above.

    When you have a chance, can you please check whether its updated on your end as well now?

  • Gayle_10863666
    Gayle_10863666 Member Posts: 32

    Hello Rav, yes they have all updated now, this is weird! I deleted the bank payment as mentioned yesterday and then granted you access, I didn't use it after that. Weird if deleting the bank payment has triggered something to update. Anyway, all have now updated in the employee records with the latest pay run accruals and are now the same as the pay slips and leave report. Thank you for your time - Regards Gayle

  • Rav
    Rav Administrator, Reckon Staff Posts: 15,092 Community Manager Community Manager

    Hi Gayle, glad to hear its updated but can I ask a favour and just ask you to keep an eye on this for the next pay run you create.

    Its a bit strange and not something I've seen before so I'd be pretty keen just to keep track of this moving forward.

    Cheers!

  • Gayle_10863666
    Gayle_10863666 Member Posts: 32

    No problem Rav, will advise next fortnightly pay run. Regards Gayle.