Single Touch Payroll Formatting issues?

  • 1
  • Problem
  • Updated 3 months ago
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

I am having alot of trouble sending off STP files via RECKON ONE. 

The error message was: "Request was incorrectly formatted or was missing required items."

I had checked 3 times on all the required fields as listed on: http://kb.reckon.com.au/issue_view.asp?ID=5663 . All items seems to be OK. 

I also called RECKON ONE support, but they just asked me to check every employee items. (which i did, again).

I know there is NOT a problem with any link with the ATO because I had successfully sent STP for one employee. 

Can RECKON please provide a bit more support in regards to this. It would be helpful to know exactly what is wrong with the inputs. 
Photo of Swee

Swee

  • 170 Points 100 badge 2x thumb
  • frustrated

Posted 4 months ago

  • 1
Photo of Rav

Rav, Community Manager

  • 64,378 Points 50k badge 2x thumb
Hi Swee,
You've mentioned you've successfully submitted an STP file previously, so just checking, on this attempt are you trying to submit for the same employee or additional/different employees?

Does every employee have ONE email address, phone number and employee number listed against them and without any special/invalid characters in these fields?
(Edited)
Photo of Rav

Rav, Community Manager

  • 64,378 Points 50k badge 2x thumb
Also, where in the process do you encounter this message?

When clicking Send to GovConnect or when submitting the pay event in GovConnect STP?
Photo of Swee

Swee

  • 170 Points 100 badge 2x thumb
Hi Rav,

I was submitting for additional/different employees. 

It could be that more than one employee have different email addresses. I will check that.

What are special/invalid characters? I have deleted "-" and "()" for example.

I clicked "sent to GovConnect STP"  in the STP page. 
Photo of Rav

Rav, Community Manager

  • 64,378 Points 50k badge 2x thumb
Different email addresses are ok, but each employee can only have one email address rather than 2 or 3 or more.

In regard to special characters, yes they are symbols like quotation marks, dashes, brackets, slashes etc. Ensure that these fields only contain numbers or letters as required.

Also, check that you don't have any leading or trailing spaces before or after a phone number or email address
Photo of Swee

Swee

  • 170 Points 100 badge 2x thumb
Hi Rav

I have done what you have advised, and still no success. 

How can I know what is wrong exactly? Its like finding a needle in a haystack.

Swee
Photo of Rav

Rav, Community Manager

  • 64,378 Points 50k badge 2x thumb
Are you still receiving the same error message mentioned in your opening post or something different now?
Photo of Swee

Swee

  • 170 Points 100 badge 2x thumb
Its the same message
  • Request was incorrectly formatted or was missing required items.

This conversation is no longer open for comments or replies.